Windows7機で原因不明?のネットワークトラブルが発生

Windows7がプリインストールされたPCが原因で、突然ネットワークが異常に重くなり、場合によっては切断されてしまう現象が発生している。
ハブに繋がっているPCのネットワークが全て異常に遅くなる事態が発生し、ハブの故障かと思い交換するも復旧せず、最終的にWindows7機のLANケーブルを抜いたら復旧。
再起動したら治ったため、とりあえず様子見しているが、今のところ原因不明。
同時期に入れたPCでも全く発生しないものもあれば、再発を繰り返す物もある。
原因はLANケーブル?…引き続き調査中。

WindowsXP SP3へのアップデートでいきなり再起動

Windows XP Service Pack 2の製品サポートが終了するとの事で、管理を依頼されているパソコン2台をService Pack 3にアップデート。
ところが最後のステップに入るぐらいでいきなり再起動し、
Setup was interrupted. Restoring prior configuration.
のメッセージとともにSP3のインストール前の状況への復旧作業(ロールバック)が開始、最終的にXPが起動した後に「ロールバック処理のステップ2を完了するには…」云々のメッセージが出て「OK」を押して復旧を継続するように促してきた。
とりあえずインストール前の状態に復旧したものの、このままではSP3が当てられない。
ほぼ同仕様の1台は問題無くインストールできたので、可能性があるとしたら増設してあるGeForce 9600か、USBストレージ等。
とりあえず、片方はUSBを全部抜いて、もう片方はVGAモードで起動(XP起動時にF8を押して選択)してSP3をインストール。
残念ながら、最初と同じタイミングで再起動してロールバック。
最後の手段?として、GeForce 9600を抜いて内蔵VGAに切り替えてSP3をインストール。
ようやく正常にインストールできた。(厳密に言えばクリーンアップが完了しなかったが、爆)
確かにGeForce 9600って、SP2とSP3で使用するドライバが違ってたもんなぁ。
にしても、めんどくさい事だ。

Outlook2007でメールが送信されない(送信トレイに残ったままになる)

Windows7が発売されてうちの会社でも評価機が導入され、私のところに回ってきた。
Vistaを使う気はさらさら無かったので、いそいそと現行のPC(Xp)から移行。
今回、SUGOI CABLE EASY PROを移行に使ったので、大した手間もなく(転送時間はそれなりにかかったが、笑)移行完了。
ところが、Outlook2007でメールの受信はできるものの送信されない(送信トレイに残ったままになる)というトラブルが発生。
もちろん「接続したら直ちに送信する」にチェックは入っているし、「終了時に自動的に送受信を実行する」にもなっている。
「アカウントの設定のテスト」をしてみると正常に送信できるし???。
メールサーバのログを確認してみると「アカウントの設定のテスト」の際のメール送信ログは残っているものの、送受信ボタンを押した際の送信ログは残っていない。(Outlookの送受信の進捗度ではエラーなしに正常に送信した事になっている。)
どうも送信トレイにメールがあるにもかかわらず、Outlookがメールの送信を怠っているようである。(メールサーバにはsmtpの接続のログすらない。)
でも、Outlookを終了しようとすると、未送信のメールがあると言ってくるんだよねぇ…(爆)
アカウントを作成し直しても同じなので、最後の手段?個人用フォルダファイルの作成し直しを行ってみた。
やり方は簡単に言うと、
1.個人用フォルダのエクスポート
2.個人用フォルダファイル「Outlook.pst」の削除
3.Outlook起動による個人用フォルダファイル「Outlook.pst」の自動再作成
4.エクスポートした個人用フォルダのインポート
の順。
作り直した後、新しくメールを作成して送信してみると…おおっ、送れた!!
送信ファイルに残っていたメールも、メールを開いて「送信ボタン」を押すと無事送ることができた。
ツールを使って、Outlook2003(Xp)→Outlook2007(7)のメールの移行を行ったのだが、それが悪かったのかしらん?
ということで、以下メモ
・Outlookを起動
・「ファイル」→「インポートとエクスポート」で「インポート/エクスポートウィザード」を起動
・「ファイルにエクスポート」を選択
・「エクスポートするファイルの種類」は「個人用フォルダファイル(pst)」を選択
・エクスポートするフォルダは最上位の「個人用フォルダ」を選び「サブフォルダを含む」にチェック
・「エクスポートファイル名」は標準で「backup.pst」なので「Original.pst」と適当な名前を入力
・オプションは「重複した場合、エクスポートするアイテムと置き換える」を選択
・「完了」ボタンを押して個人用フォルダを全部エクスポート
・エクスポート完了後、Outlookを終了
・個人用フォルダのファイルのあるフォルダを開く。(大概はC:Usersユーザー名AppDataLocalMicrosoftOutlook)
※場所が分からない場合、Outlookを起動して「ファイル」→「データファイルの管理」で位置を確認
・フォルダ中の「Outlook.pst」を「Outlook_ORG.pst」と変名
・再度Outlookを起動
・「C:Usersユーザー名AppDataLocalMicrosoftOutlookOutlook.pst」が無いと言われるが無視して「OK」
・空の「個人用フォルダ」が出来上がったら「ファイル」→「インポートとエクスポート」で再度「インポート/エクスポートウィザード」を起動
・「他のプログラムまたはファイルからのインポート」を選択
・「インポートするファイルの種類」は「個人用フォルダファイル(pst)」を選択
・インポートするファイルは、最初にエクスポートした「Original.pst」を選択
・オプションは「重複した場合、インポートするアイテムと置き換える」を選択
・インポートするフォルダの選択は「個人用フォルダ」を選択し「サブフォルダを含む」にチェック
・「以下のフォルダにアイテムをインポートする」は「個人用フォルダ」を選択
・「完了」ボタンを押して個人用フォルダを全部インポート

Symantec BackupExecの合成バックアップが使い物にならない!!

ファイルサーバのバックアップ時間の短縮のため、合成バックアップ(過去のフルバックアップと最新の増分バックアップから、最新のフルバックアップをでっち上げる機能)の利用できるBackupExecを購入したのだが、以前のトラブル対処を行っても安定して稼動しないので問い合わせたところ、こんなナレッジベースを返してきた。
http://seer.entsupport.symantec.com/docs/305115.htm
要は、バックアップ対象のディスクの容量が大きかったり多数のファイルが存在する場合、合成バックアップの追加情報収集中に処理がタイムアウトする可能性がある、しかも次のメジャーバージョンアップまで放置………おぃおぃ!?
このバージョンでは合成バックアップは使えないうえ、バージョンアップまで料金取るつもりか!!
つう事で、合成バックアップが目的でBackupExecを検討している方、他のバックアップソフトを検討したほうが良いです。
しかし困った…全部ARCServeに入れ替えさせようかしらん?

VistaのVPN接続の不具合

会社のノートPCがXPからVistaに切り替わったのだが、社内LANで使用しているVista機を外に持ち出し、VPNで社内LANに接続し、ドライブ割り当てしてある共有フォルダにアクセスしようとすると「ユーザーが存在しません」と言われて接続できないトラブルが発生した。
サーバの名前解決もできてるし、PINGも通るし、イベントピューワからするとActiveDirectoryのドメインコントローラとも通信を行っているようなのに何で???(もちろんファイアウォールも殺してある。)
唯一IPでの接続(\192.168.XXX.XXX等)の場合だけ、ユーザー名とパスワードを聞いてくるため、その際に適切なユーザー名とパスワード(ドメインにログオンする際の)を指定すればアクセス可能なのは確認できた。
ただそれでは使い勝手が悪いので、さらに調べていくと、手順を変更することで回避可能な事が解った。
通常XPだと、
1.ドメインのユーザー名、パスワードでPCにログオン
2.インターネット接続(携帯やモデムでプロバイダに接続)
※3の設定で事前に接続する設定にしてあれば自動で接続される
3.PPTP等VPNで会社に接続(ドメイン以外のユーザー名、パスワードで接続)
4.共有フォルダにアクセス
という手順であったのだが、Vistaの場合は、
1.インターネット接続(携帯やモデムでプロバイダに接続)
※2の設定で事前に接続する設定にしてあれば自動で接続される
2.PPTP等VPNで会社に接続(ドメイン以外のユーザー名、パスワードで接続)
3.PCへのログオンは失敗するが、回線及びVPNは接続されたままなので指示に従いユーザーを再選択
4.ドメインのユーザー名、パスワードでPCにログオン
5.共有フォルダにアクセス
で問題無くファイルサーバに接続可能であった。
どうやらVistaは、最後にネットワークにログオンしたユーザー名、パスワードでファイルサーバにアクセスに行くうえ、エラーになってもユーザー名とパスワードを再度聞いてこない仕様らしい。
うちの場合、VPNサーバはセキュリティ上ActiveDirectoryの管理外にしてあり、ユーザー名、パスワードもドメインのものとも変えてあるため、PCにログオン後VPNに接続するとそのアカウントが有効になり、全部弾かれてしまっていた訳だ。
ログオン前にVPN接続を完了させておくと、仮想的に社内LANに繋がった状態でログオンする事になり、全ての問題が解決するという訳らしい。
事前にVPNを接続してからPCにログオンするという手段は、Vista以前でも可能ではあったが、インターネット接続のユーザー名、パスワード、VPN接続のユーザー名、パスワード、ドメインログオンのユーザー名、パスワード、計3回認証(しかも全部手打ち…)しないとならなかったため、非常に面倒であり、やむをえずログオン後に接続するという手段を取っていた。(ログオン後であれば、事前に登録したユーザー名、パスワードで接続する事ができるため。)
Vistaでは、事前に登録したインターネットの接続先やVPN接続先が選択できるようになっており、かつVPN接続先の設定で、事前にインターネットへの接続をするようにしてあれば、VPNのユーザー名とパスワードを入力するだけでインターネットの接続〜VPNの接続まで完了するようになっている。
PCへのログオンも、アカウントを選択してパスワードだけ入れれば良いので、かなりの手間が簡略化でき、我慢できる範囲内だと思う。(VPNのアカウントがActiveDirectoryの管理下にあれば、PCへのログオンまで一括でできるため、LAN環境でログオンするのと手間はほとんど変わらない。)
しかし、ここまでたどり着くのに結構手間がかかったよ〜ふぅ…。

ORACLE10gのエンタープライズマネージャでのDBエキスポート

ORACLE10gで、本番環境のデータベースの複製をして、テスト環境を作るため、エンタープライズマネージャで、エキスポートを実行しようと思ったところ、
ORA-39094 パラレル実行はこのデータベース・エディションではサポートされていません。
というエラーが発生。
調べたところ、エンタープライズマネージャが、Enterprise Editionでしか利用できないオプション付きでSQL文を生成していて、どうやってもそのオプションを外して生成してくれない。
結局手打ちでコマンドを入力し、エキスポートするはめになってしまった。
こちとらStanderd Editionでインストールしてるんだから、それぐらい判別して、その機能を無効にするか、そのオプションつけて生成するんじゃないよ!

予備録画マシンの機能拡張その2

CPUを3GHzにしたせいで熱がこもり、CPUが70度を越してしまうので、5インチベイに取り付ける吸気ファンを買って来た。
4センチのファンが3個並んだもので、1000円弱といったところ。
ファンが2個のタイプもあったが、風量が多いほうが良いだろうとのことで3つのものに。しかしフィルタ?の取り外し方が解らず、いろいろ弄っていたらパキッと…う〜ん、やわだなぁ(^^;)
仕方ないのでフィルタは両面テープで取り付け、5インチベイにファンを装着…と思ったが、今使っているケースの、5インチベイは手前のネジ穴が無いため、本体もテープで留める羽目に(爆)
まあ、いずれきちんと処理するとしよう。
さて取り付け効果だが、明らかに後ろから排出される空気の量が増え、CPU温度も10度以上下がる結果となった。
不安だったファンのノイズだが、それほど気になるほどではなかった。とりあえずこれでしばらく使ってみてどうかだな?

ソフトライセンスの有効期限トラブル

うちが利用している、企業向けサーバーソフトのライセンス更新のFAXが届いた。
年間ライセンスのソフトなのでそれは当たり前なのだが、そのライセンス更新期限を見てびっくり!!
「あっ、あと5日しかねぇ…!!」
普通それなりの規模の会社で、それなりのお金を右から左に動かすには、それなりの期間が必要なのだ。見積もりも来ていない段階であと5日とは、いくらなんでも短すぎる!!
こちらが更新を忘れていたのなら仕方がないが、こちらの想定していたそのソフトの更新日まで、少なくともあと二ヶ月はあるはずなのに、あと5日とはこれいかに!?
ということで、販売先に確認すると、ライセンスの期限は「購入日から一年間」だそうな。
おいおい、そんなん初めて聞いたぞ。しかもホームページ上でライセンス番号を取得した時のメッセージには、ライセンスの有効期限はライセンス番号を取得してから一年間って書いてあったぞ。(当たり前だが、ハードコピーを取って保存してあるのだ。)
そしたら、そのシステムには不具合があったため、その旨説明してお詫びのメールを送付してあり、他のユーザーには納得してもらっているとの事。
ちょっと待てよ、うちにはそのメールは届いてないし、もしそれが不具合だったとしたら、一度テストすればわかるようなあからさまな不具合だぞ?(一日でも登録が遅れると、ライセンスの有効期限が違って表示されるんだから。)
その際に表示されるメッセージやら加味すると、システムの不具合と言っているが、実のところ製造元と販社のライセンスの概念に食い違いがあったんじゃないのか?そう勘ぐりたくなるな。
で、結局どうなったのかというと、こちらには非は無いので?大人の対応をしていただきました(爆)